Add further missing Build-Depends (really)
[senf.git] / debian / rules
index 7820942..8f1cefc 100755 (executable)
@@ -19,15 +19,11 @@ export debian_build
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
 
-#DPKG_ARCH#
-
 CFLAGS = -Wall -g
 
 CONCURRENCY_LEVEL ?= 1
 export CONCURRENCY_LEVEL
 
-LIBTYPE ?= UNSPEC
-
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
@@ -39,7 +35,7 @@ destdir=$(CURDIR)/debian/tmp
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-#      # Add here commands to configure the package.
+#      Add here commands to configure the package.
        rm -f Doxyfile.local SConfig local_config.hh
        scons prepare
 #       If needed, we could create new files 'Doxyfile.local',
@@ -76,10 +72,13 @@ build-indep-stamp: configure-stamp
        scons all_docs
        scons linklint
        scons fixlinks
-       scons $(destdir)/usr/include $(destdir)/usr/share/doc $(SCONS_OPTIONS) \
+       scons $(destdir)/usr/include $(destdir)/usr/share/doc \
                PREFIX='$(destdir)/usr' \
-               DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc' \
+               DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc/html' \
                INCLUDEINSTALLDIR='$$PREFIX/include/senf' 
+#      Remove all the files not really needed from the documentation directories
+       find $(destdir)/usr/share/doc/libsenf-doc/html \
+               -type f ! -regex '.*\.\(html\|css\|png\|php\|idx\|tag\)' | xargs rm -f
 #       We need to install the example sourcecode
        find Examples \( -name "*.hh" -o -name "*.cc" \) -printf "%P\n" | \
                while read src; do \
@@ -155,6 +154,7 @@ binary-indep: build-indep install-indep
        $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
 
 binary-arch: build-arch install-arch
+       $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
 
 binary: binary-arch binary-indep
 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch \