debian: Move documentation into 'html' subdir
[senf.git] / debian / rules
index 7820942..911d1b8 100755 (executable)
@@ -78,8 +78,11 @@ build-indep-stamp: configure-stamp
        scons fixlinks
        scons $(destdir)/usr/include $(destdir)/usr/share/doc $(SCONS_OPTIONS) \
                PREFIX='$(destdir)/usr' \
-               DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc' \
+               DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc/html' \
                INCLUDEINSTALLDIR='$$PREFIX/include/senf' 
+#      Remove all the files not really needed from the documentation directories
+       find $(destdir)/usr/share/doc/libsenf-doc/html \
+               -type f ! -regex '.*\.\(html\|css\|png\|php\|idx\|tag\)' | xargs rm -f
 #       We need to install the example sourcecode
        find Examples \( -name "*.hh" -o -name "*.cc" \) -printf "%P\n" | \
                while read src; do \
@@ -155,6 +158,7 @@ binary-indep: build-indep install-indep
        $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
 
 binary-arch: build-arch install-arch
+       $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
 
 binary: binary-arch binary-indep
 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch \