minor fixes for clang++
[senf.git] / debian / rules
index 3df60cc..4899207 100755 (executable)
@@ -61,14 +61,15 @@ build-arch-debug-stamp: configure-stamp
 build-indep: build-indep-stamp
 build-indep-stamp: configure-stamp
 #      Add here commands to compile the indep part of the package.
-       scons -j $(CONCURRENCY_LEVEL) all_docs
-       scons linklint
-       scons fixlinks
-       scons $(destdir)/usr/include $(destdir)/usr/share/doc \
-               syslayout=1 PREFIX='$(destdir)/usr' \
-               DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc/html'
+#      scons -j $(CONCURRENCY_LEVEL) all_docs
+#      scons linklint
+#      scons fixlinks
+#      scons $(destdir)/usr/include $(destdir)/usr/share/doc \
+#              syslayout=1 PREFIX='$(destdir)/usr' \
+#              DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc/html'
+       scons $(destdir)/usr/include syslayout=1 PREFIX='$(destdir)/usr'
 #       We need to install the example sourcecode
-       find Examples \( -name "*.hh" -o -name "*.cc" \) -printf "%P\n" | \
+       find Examples \( -name "*.hh" -o -name "*.cc" -o -name SConstruct \) -printf "%P\n" | \
                while read src; do \
                        dir="$(destdir)/usr/share/doc/libsenf-doc/examples/$$(dirname "$$src")"; \
                        mkdir -p "$$dir"; \
@@ -95,7 +96,7 @@ install-indep: build-indep
        dh_installdirs -i
 #      Add here commands to install the indep part of the package into
 #      debian/<package>-doc.
-       dh_install -X.svn -i
+       dh_install -X.svn -X.git -i
 
 install-arch: build-arch
        dh_testdir
@@ -104,7 +105,7 @@ install-arch: build-arch
        dh_installdirs -s
 #      Add here commands to install the arch part of the package into 
 #      debian/tmp.
-       dh_install -X.svn -s
+       dh_install -X.svn -X.git -s
 
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep