minor fixes for clang++
[senf.git] / debian / rules
index 911d1b8..4899207 100755 (executable)
@@ -19,72 +19,57 @@ export debian_build
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
 
-#DPKG_ARCH#
-
-CFLAGS = -Wall -g
-
 CONCURRENCY_LEVEL ?= 1
 export CONCURRENCY_LEVEL
 
-LIBTYPE ?= UNSPEC
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
 destdir=$(CURDIR)/debian/tmp
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-#      # Add here commands to configure the package.
-       rm -f Doxyfile.local SConfig local_config.hh
+#      Add here commands to configure the package.
+#      rm -f Doxyfile.local SConstruct.local senf/local_config.hh
        scons prepare
 #       If needed, we could create new files 'Doxyfile.local',
-#       'SConfig' and/or 'local_config.hh' here.  We don't remove them
-#       in 'clean' to allow building a source package from an
-#       individually configured svn working copy. (The files are ignored
-#       by dpkg-buildpackge because of appropriate -I arguments provided 
-#       by 'scons deb' and 'scons debsrc'
+#       'SConstruct.local' and/or 'local_config.hh' here.  We don't
+#       remove them in 'clean' to allow building a source package from
+#       an individually configured svn working copy. (The files are
+#       ignored by dpkg-buildpackge because of appropriate -I
+#       arguments provided by 'scons deb' and 'scons debsrc'
        touch configure-stamp
 
 build: build-arch build-indep
 
-build-arch: build-arch-final build-arch-debug
+build-arch: build-arch-debug build-arch-final
 
 build-arch-final: build-arch-final-stamp
 build-arch-final-stamp: configure-stamp
 #      Add here commands to compile the arch part of the package.
-       scons -j $(CONCURRENCY_LEVEL) default final=1
-       scons $(destdir)/usr/lib final=1 PREFIX='$(destdir)/usr'
+       scons -j $(CONCURRENCY_LEVEL) $(destdir)/usr/lib $(destdir)/usr/bin \
+               final=1 syslayout=1 \
+               PREFIX='$(destdir)/usr' OBJINSTALLDIR='$$PREFIX/lib/senf/final'
        touch $@
 
 build-arch-debug: build-arch-debug-stamp
 build-arch-debug-stamp: configure-stamp
 #      Add here commands to compile the arch part of the package.
-       scons -j $(CONCURRENCY_LEVEL) default LIBADDSUFFIX=_g OBJADDSUFFIX=_g
-       scons $(destdir)/usr/lib LIBADDSUFFIX=_g OBJADDSUFFIX=_g \
-               PREFIX='$(destdir)/usr' OBJINSTALLDIR='$$LIBINSTALLDIR/debug'
+               scons -j $(CONCURRENCY_LEVEL) $(destdir)/usr/lib \
+               LIBADDSUFFIX=_g OBJADDSUFFIX=_g syslayout=1 \
+               PREFIX='$(destdir)/usr' OBJINSTALLDIR='$$PREFIX/lib/senf/debug'
        touch $@
 
 build-indep: build-indep-stamp
 build-indep-stamp: configure-stamp
 #      Add here commands to compile the indep part of the package.
-       scons -j $(CONCURRENCY_LEVEL) all_docs
-       scons all_docs
-       scons linklint
-       scons fixlinks
-       scons $(destdir)/usr/include $(destdir)/usr/share/doc $(SCONS_OPTIONS) \
-               PREFIX='$(destdir)/usr' \
-               DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc/html' \
-               INCLUDEINSTALLDIR='$$PREFIX/include/senf' 
-#      Remove all the files not really needed from the documentation directories
-       find $(destdir)/usr/share/doc/libsenf-doc/html \
-               -type f ! -regex '.*\.\(html\|css\|png\|php\|idx\|tag\)' | xargs rm -f
+#      scons -j $(CONCURRENCY_LEVEL) all_docs
+#      scons linklint
+#      scons fixlinks
+#      scons $(destdir)/usr/include $(destdir)/usr/share/doc \
+#              syslayout=1 PREFIX='$(destdir)/usr' \
+#              DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc/html'
+       scons $(destdir)/usr/include syslayout=1 PREFIX='$(destdir)/usr'
 #       We need to install the example sourcecode
-       find Examples \( -name "*.hh" -o -name "*.cc" \) -printf "%P\n" | \
+       find Examples \( -name "*.hh" -o -name "*.cc" -o -name SConstruct \) -printf "%P\n" | \
                while read src; do \
                        dir="$(destdir)/usr/share/doc/libsenf-doc/examples/$$(dirname "$$src")"; \
                        mkdir -p "$$dir"; \
@@ -111,7 +96,7 @@ install-indep: build-indep
        dh_installdirs -i
 #      Add here commands to install the indep part of the package into
 #      debian/<package>-doc.
-       dh_install -X.svn -i
+       dh_install -X.svn -X.git -i
 
 install-arch: build-arch
        dh_testdir
@@ -120,7 +105,7 @@ install-arch: build-arch
        dh_installdirs -s
 #      Add here commands to install the arch part of the package into 
 #      debian/tmp.
-       dh_install -X.svn -s
+       dh_install -X.svn -X.git -s
 
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep