minor fixes for clang++
[senf.git] / debian / rules
index a7d1b80..4899207 100755 (executable)
@@ -45,34 +45,31 @@ build-arch: build-arch-debug build-arch-final
 build-arch-final: build-arch-final-stamp
 build-arch-final-stamp: configure-stamp
 #      Add here commands to compile the arch part of the package.
-       scons -j $(CONCURRENCY_LEVEL) default final=1
-       scons $(destdir)/usr/lib $(destdir)/usr/bin final=1 syslayout=1 \
-               PREFIX='$(destdir)/usr' OBJINSTALLDIR='$$PREFIX/lib/senf'
+       scons -j $(CONCURRENCY_LEVEL) $(destdir)/usr/lib $(destdir)/usr/bin \
+               final=1 syslayout=1 \
+               PREFIX='$(destdir)/usr' OBJINSTALLDIR='$$PREFIX/lib/senf/final'
        touch $@
 
 build-arch-debug: build-arch-debug-stamp
 build-arch-debug-stamp: configure-stamp
 #      Add here commands to compile the arch part of the package.
-       scons -j $(CONCURRENCY_LEVEL) default LIBADDSUFFIX=_g OBJADDSUFFIX=_g
-       scons $(destdir)/usr/lib syslayout=1 LIBADDSUFFIX=_g OBJADDSUFFIX=_g \
+               scons -j $(CONCURRENCY_LEVEL) $(destdir)/usr/lib \
+               LIBADDSUFFIX=_g OBJADDSUFFIX=_g syslayout=1 \
                PREFIX='$(destdir)/usr' OBJINSTALLDIR='$$PREFIX/lib/senf/debug'
        touch $@
 
 build-indep: build-indep-stamp
 build-indep-stamp: configure-stamp
 #      Add here commands to compile the indep part of the package.
-       scons -j $(CONCURRENCY_LEVEL) all_docs
-       scons all_docs
-       scons linklint
-       scons fixlinks
-       scons $(destdir)/usr/include $(destdir)/usr/share/doc syslayout=1 \
-               PREFIX='$(destdir)/usr' \
-               DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc/html'
-#      Remove all the files not really needed from the documentation directories
-       find $(destdir)/usr/share/doc/libsenf-doc/html \
-               -type f ! -regex '.*\.\(html\|css\|png\|php\|idx\|tag\)' | xargs rm -f
+#      scons -j $(CONCURRENCY_LEVEL) all_docs
+#      scons linklint
+#      scons fixlinks
+#      scons $(destdir)/usr/include $(destdir)/usr/share/doc \
+#              syslayout=1 PREFIX='$(destdir)/usr' \
+#              DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc/html'
+       scons $(destdir)/usr/include syslayout=1 PREFIX='$(destdir)/usr'
 #       We need to install the example sourcecode
-       find Examples \( -name "*.hh" -o -name "*.cc" \) -printf "%P\n" | \
+       find Examples \( -name "*.hh" -o -name "*.cc" -o -name SConstruct \) -printf "%P\n" | \
                while read src; do \
                        dir="$(destdir)/usr/share/doc/libsenf-doc/examples/$$(dirname "$$src")"; \
                        mkdir -p "$$dir"; \
@@ -99,7 +96,7 @@ install-indep: build-indep
        dh_installdirs -i
 #      Add here commands to install the indep part of the package into
 #      debian/<package>-doc.
-       dh_install -X.svn -i
+       dh_install -X.svn -X.git -i
 
 install-arch: build-arch
        dh_testdir
@@ -108,7 +105,7 @@ install-arch: build-arch
        dh_installdirs -s
 #      Add here commands to install the arch part of the package into 
 #      debian/tmp.
-       dh_install -X.svn -s
+       dh_install -X.svn -X.git -s
 
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep