Rework debian package build: build final and debug packages and split off include...
[senf.git] / debian / rules
index f1921e0..4d2782e 100755 (executable)
@@ -1,10 +1,14 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
 # Sample debian/rules that uses debhelper.
+#
 # This file was originally written by Joey Hess and Craig Small.
 # As a special exception, when this file is copied by dh-make into a
 # dh-make output file, you may use that output file without restriction.
 # This special exception was added by Craig Small in version 0.37 of dh-make.
+#
+# Modified to make a template file for a multi-binary package with separated
+# build-arch and build-indep targets  by Bill Allombert 2001
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 debian_build=1
 export debian_build
 
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+
+#DPKG_ARCH#
+
 CFLAGS = -Wall -g
 
 CONCURRENCY_LEVEL ?= 1
+export CONCURRENCY_LEVEL
+
+LIBTYPE ?= UNSPEC
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -22,15 +34,6 @@ else
        CFLAGS += -O2
 endif
 
-# shared library versions, option 1
-#version=2.0.5
-#major=2
-# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
-#version=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
-#major=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
-
 destdir=$(CURDIR)/debian/tmp
 
 configure: configure-stamp
@@ -47,30 +50,42 @@ configure-stamp:
 #       by 'scons deb' and 'scons debsrc'
        touch configure-stamp
 
-build: build-stamp
-build-stamp: configure-stamp 
-       dh_testdir
-#      # Add here commands to compile the package.
-       scons -j $(CONCURRENCY_LEVEL) default all_docs final=1
+build: #build-arch build-indep
+
+build-arch: build-arch-$(LIBTYPE)-stamp
+build-arch-$(LIBTYPE)-stamp: configure-stamp
+#      Add here commands to compile the arch part of the package.
+       scons -j $(CONCURRENCY_LEVEL) default $(SCONS_OPTIONS)
+       touch $@
+
+build-indep: build-indep-stamp
+build-indep-stamp: configure-stamp
+#      Add here commands to compile the indep part of the package.
+       scons -j $(CONCURRENCY_LEVEL) all_docs
        scons linklint
        scons fixlinks
        touch $@
 
-clean:
+clean: debclean
+#      Add here commands to clean up after the build process.
+       -scons -c all
+       -scons -c all LIBSENF=senf_g
+
+debclean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-#      # Add here commands to clean up after the build process.
-       -scons -c all
+       rm -f build-arch-*-stamp build-indep-stamp configure-stamp
        dh_clean
 
-install: build
+install: #install-indep install-arch
+install-indep: build-indep
        dh_testdir
        dh_testroot
-       dh_clean -k 
-       dh_installdirs
-#      # Add here commands to install the package into debian/tmp
-       scons install_all final=1 \
+       dh_clean -k -i
+       dh_installdirs -i
+#      Add here commands to install the indep part of the package into
+#      debian/<package>-doc.
+       scons $(destdir)/usr/include $(destdir)/usr/share/doc $(SCONS_OPTIONS) \
                PREFIX='$(destdir)/usr' \
                DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc' \
                INCLUDEINSTALLDIR='$$PREFIX/include/senf' 
@@ -81,41 +96,72 @@ install: build
                        mkdir -p "$$dir"; \
                        cp "Examples/$$src" "$$dir"; \
                done
+       dh_install -X.svn -i
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+install-arch: build-arch
+       dh_testdir
+       dh_testroot
+       dh_clean -k -s
+       dh_installdirs # options provided by DH_OPTIONS
+#      Add here commands to install the arch part of the package into 
+#      debian/tmp.
+       scons $(destdir)/usr/lib $(SCONS_OPTIONS) PREFIX='$(destdir)/usr'
+       dh_install -X.svn # options provided by DH_OPTIONS
 
-# Build architecture-dependent files here.
-binary-arch: build install
+# Must not depend on anything. This is to be called by
+# binary-arch/binary-indep
+# in another 'make' thread.
+binary-common:
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
-       dh_install
 #      dh_installmenu
 #      dh_installdebconf       
-#      dh_installlogrotate
+#      dh_installlogrotate     
 #      dh_installemacsen
 #      dh_installpam
 #      dh_installmime
+#      dh_python
 #      dh_installinit
 #      dh_installcron
 #      dh_installinfo
        dh_installman
        dh_link
        dh_strip
-       dh_compress
+       dh_compress -Xhtml -Xdoclib -Xexamples
        dh_fixperms
 #      dh_perl
-#      dh_python
-#      dh_makeshlibs
+       dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary-indep: build-indep install-indep
+       $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
+
+binary-arch: binary-arch-final binary-arch-debug
+
+binary-arch-final:
+       $(MAKE) -f debian/rules \
+               DH_OPTIONS="-s -Nlibsenf-dbg" \
+               SCONS_OPTIONS="final=1" \
+               LIBTYPE="final" \
+                       binary-arch-common
+
+binary-arch-debug:
+       $(MAKE) -f debian/rules \
+               DH_OPTIONS="-plibsenf-dbg" \
+               SCONS_OPTIONS="LIBSENF=senf_g" \
+               LIBTYPE="debug" \
+                       binary-arch-common
+
+binary-arch-common: build-arch install-arch
+       $(MAKE) -f debian/rules DH_OPTIONS="$(DH_OPTIONS)" binary-common
+
+binary: binary-arch binary-indep
+.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch \
+       binary-arch-common binary-arch-final binary-arch-debug