Improve handling of SConfig and Doxyfile.local in debian build
[senf.git] / debian / rules
index 4491055..558debd 100755 (executable)
@@ -23,8 +23,8 @@ else
 endif
 
 # shared library versions, option 1
-version=2.0.5
-major=2
+#version=2.0.5
+#major=2
 # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
 #version=`ls src/.libs/lib*.so.* | \
 # awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
@@ -37,14 +37,18 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
 #      # Add here commands to configure the package.
+       rm -f Doxyfile.local SConfig
+#       If needed, we could create new 'Doxyfile.local' and/or 'SConfig' files here.
+#       We don't remove them in 'clean' to allow building a source package from an 
+#       individually configured svn working copy.
        touch configure-stamp
 
-
 build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 #      # Add here commands to compile the package.
-       scons -j $(CONCURRENCY_LEVEL) all final=1
+       scons -j $(CONCURRENCY_LEVEL) final=1
+       scons -j $(CONCURRENCY_LEVEL) all_docs final=1
        touch $@
 
 clean:
@@ -53,7 +57,7 @@ clean:
        rm -f build-stamp configure-stamp
 #      # Add here commands to clean up after the build process.
        -scons -c all
-       dh_clean 
+       dh_clean
 
 install: build
        dh_testdir
@@ -61,7 +65,7 @@ install: build
        dh_clean -k 
        dh_installdirs
 #      # Add here commands to install the package into debian/tmp
-       scons install_all final=1\
+       scons -j $(CONCURRENCY_LEVEL) install_all final=1\
                PREFIX='$(destdir)/usr' \
                DOCINSTALLDIR='$$PREFIX/share/doc/libsenf-doc'
 #       We need to install the example sourcecode