Debianization
[udpcat.git] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..bfb5508
--- /dev/null
@@ -0,0 +1,83 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+#
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+#
+# Modified to make a template file for a multi-binary package with separated
+# build-arch and build-indep targets  by Bill Allombert 2001
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+
+CONCURRENCY_LEVEL ?= 1
+export CONCURRENCY_LEVEL
+
+destdir=$(CURDIR)/debian/tmp
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp
+#      Add here commands to compile the arch part of the package.
+       scons -j $(CONCURRENCY_LEVEL)
+       touch $@
+
+clean: debclean
+#      Add here commands to clean up after the build process.
+       -scons -c all
+
+debclean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k -s -Xdebian/tmp
+       dh_installdirs -s
+#      Add here commands to install the arch part of the package into 
+#      debian/tmp.
+       dh_install -X.svn -X.git -s
+
+binary: build install
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs
+       dh_installdocs
+       dh_installexamples
+#      dh_installmenu
+#      dh_installdebconf       
+#      dh_installlogrotate     
+#      dh_installemacsen
+#      dh_installpam
+#      dh_installmime
+#      dh_python
+#      dh_installinit
+#      dh_installcron
+#      dh_installinfo
+       dh_installman
+       dh_link
+       dh_strip
+       dh_compress -Xhtml -Xdoclib -Xexamples
+       dh_fixperms
+#      dh_perl
+       dh_makeshlibs
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+.PHONY: configure build clean debclean install binary