Fix 'buildout.cfg' modification code
[zope-bootstrap.git] / skel-zope3 / setup.py
diff --git a/skel-zope3/setup.py b/skel-zope3/setup.py
new file mode 100644 (file)
index 0000000..c0f76c4
--- /dev/null
@@ -0,0 +1,58 @@
+from setuptools import setup, find_packages
+
+setup(name='appmain',
+
+      # Fill in project info below
+      version='0.1',
+      description="",
+      long_description="",
+      keywords='',
+      author='',
+      author_email='',
+      url='',
+      license='',
+      # Get more from http://www.python.org/pypi?%3Aaction=list_classifiers
+      classifiers=['Programming Language :: Python',
+                   'Environment :: Web Environment',
+                   'Topic :: Internet :: WWW/HTTP :: WSGI :: Application',
+                   'Framework :: Zope3',
+                   ],
+
+      packages=find_packages('src'),
+      package_dir = {'': 'src'},
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=['setuptools',
+                        'ZODB3',
+                        'ZConfig',
+                        'zdaemon',
+                        'zope.publisher',
+                        'zope.traversing',
+                        'zope.app.wsgi>=3.4.0',
+                        'zope.app.appsetup',
+                        'zope.app.zcmlfiles',
+                        # The following packages aren't needed from the
+                        # beginning, but end up being used in most apps
+                        'zope.annotation',
+                        'zope.copypastemove',
+                        'zope.formlib',
+                        'zope.i18n',
+                        'zope.app.authentication',
+                        'zope.app.session',
+                        'zope.app.intid',
+                        'zope.app.keyreference',
+                        'zope.app.catalog',
+                        # The following packages are needed for functional
+                        # tests only
+                        'zope.testing',
+                        'zope.app.testing',
+                        'zope.app.securitypolicy',
+                        ],
+      entry_points = """
+      [console_scripts]
+      appmain-debug = appmain.startup:interactive_debug_prompt
+      appmain-ctl = appmain.startup:zdaemon_controller
+      [paste.app_factory]
+      main = appmain.startup:application_factory
+      """
+      )